当前位置: 首页 > Java > 正文

Attribute “scope” must be declared for element type “bean”.

关键字:
1 星2 星3 星4 星5 星 (暂无评分)
Loading ... Loading ...
baidu_share

把一份编码为GB2312的spring xml文档转换为UTF-8后,发现在bean 属性的scope=”prototype”出现Attribute “scope” must be declared for element type “bean”错误。

原因:Attribute “scope” 在spring2.0以后支持。
把xml头改为:

<!DOCTYPE beans PUBLIC "-//SPRING//DTD BEAN 2.0//EN" "http://www.springframework.org/dtd/spring-beans-2.0.dtd">

或者:

<!DOCTYPE beans PUBLIC "-//SPRING//DTD BEAN//EN" "http://www.springframework.org/dtd/spring-beans-2.0.dtd">

本文固定链接: http://www.chepoo.com/attribute-scope-must-be-declared-for-element-type-bean.html | IT技术精华网

【上一篇】
【下一篇】

Attribute “scope” must be declared for element type “bean”.:等您坐沙发呢!

发表评论